WSM-02557 When Trying to Deploy On SOA Server.

AdminServer indicates to the following error:-

AdminServer-diagnostic.log:[2014-07-16T10:40:43.681+02:00] [AdminServer] [ERROR] [WSM-02353] [oracle.wsm.resources.policymanager] [tid: [ACTIVE].ExecuteThread: ‘0’ for queue: ‘weblogic.kernel.Default (self-tuning)’] [userId: admin] [ecid: bf57ca3361a7ecd1:-39746f30:1473e26749c:-8000-000000000000026a,0] [APP: em] Unable to get the Action Executor.

to solve this issue make sure the following Users were created in Weblogic console :-

From AdminConsole –> Security —> myrealms –> Choose Users and Group Tab.

Create the below user :-

OracleSystemUser

Create the below Group

OracleSystemGroup

The following Pictures describes users and Group ( how supposed to be ) :-

and assign this group to OracleSystemUser , Restart Console and managed Server Try again.

Thank you
Osama Mustafa

10 thoughts on “WSM-02557 When Trying to Deploy On SOA Server.

  1. hi osama, Testing a web service(in EM) which is deployed in admin server .Home >Summary of Security Realms >myrealm >Users and Groups > OracleSystemUser is listed and DefaultAuthenticator is the provider for that user. but still am getting below error . please help me out.java.lang.Exception: oracle.sysman.emSDK.webservices.wsdlapi.SoapTestException: oracle.fabric.common.PolicyEnforcementException: PolicySet Invalid: WSM-02557 oracle.wsm.policymanager.accessor.BeanAccessor The documents required to configure the Oracle Web Services Manager runtime have not been retrieved from the Policy Manager application (wsm-pm), possibly because the application is not running or has not been deployed in the environment. The query “&(policysets:global/%)(@appliesTo~=”WS-Client()”)” is queued for later retrieval. WSM-02557 oracle.wsm.policymanager.accessor.BeanAccessor The documents required to configure the Oracle Web Services Manager runtime have not been retrieved from the Policy Manager application (wsm-pm), possibly because the application is not running or has not been deployed in the environment. The query “/policies/oracle/wss11_x509_token_with_message_protection_client_policy” is queued for later retrieval. at oracle.sysman.emas.model.wsmgt.WSTestModel.invokeOperation(WSTestModel.java:813) at

    Like

  2. Hi kalyan,Did you get the solution for this issue? I have the OracleSystemUser. But still facing the issue. Please let me know If you find the solution.Thankyou

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.