WSM-02557 When Trying to Deploy On SOA Server.

AdminServer indicates to the following error:-

AdminServer-diagnostic.log:[2014-07-16T10:40:43.681+02:00] [AdminServer] [ERROR] [WSM-02353] [oracle.wsm.resources.policymanager] [tid: [ACTIVE].ExecuteThread: ‘0’ for queue: ‘weblogic.kernel.Default (self-tuning)’] [userId: admin] [ecid: bf57ca3361a7ecd1:-39746f30:1473e26749c:-8000-000000000000026a,0] [APP: em] Unable to get the Action Executor.

to solve this issue make sure the following Users were created in Weblogic console :-

From AdminConsole –> Security —> myrealms –> Choose Users and Group Tab.

Create the below user :-

OracleSystemUser

Create the below Group

OracleSystemGroup

The following Pictures describes users and Group ( how supposed to be ) :-

and assign this group to OracleSystemUser , Restart Console and managed Server Try again.

Thank you
Osama Mustafa

SOA_SERVER ( Managed Server ) Take too Long time to Start/Restart

On the weblogic console when trying to start managed Server it’s take too long time to start in my case it’s SOA_SERVER, almost 25 min only to start, which is not correct . to avoid this problem you need to follow the below steps simple but effective :-

Under Java Home ( That Used by Weblogic ) :-

cd /u01/app/fmw/jdk/jre/lib/security 

There’s file called Java.Security 

Edit this File using any Editor ( vi for example ).

Search for the following line :-

securerandom.source=file:/dev/urandom

And Change it to :-

securerandom.source=file:/dev/./urandom

Or Another way add the below line to startup script in weblogic :-

-Djava.security.egd=file:/dev/./urandom

Hope this will solve your problem.

Thank you
Osama Mustafa

Invalid User name and password OBIEE 11g (Analytics)

When trying to Access to the URL:// hostname:9704/analytics with username weblogic the below error generated in the Adminserver logs :-

java.security.AccessControlException: access denied (oracle.security.jps.service.credstore.CredentialAccessPermission context=SYSTEM,mapName=oracle.bi.system,keyName=system.user read)
at java.security.AccessControlContext.checkPermission(AccessControlContext.java:374)
at java.security.AccessController.checkPermission(AccessController.java:546)
at oracle.security.jps.util.JpsAuth$AuthorizationMechanism$3.checkPermission(JpsAuth.java:463)
at oracle.security.jps.util.JpsAuth.checkPermission(JpsAuth.java:523)
at oracle.security.jps.util.JpsAuth.checkPermission(JpsAuth.java:549)
at oracle.security.jps.internal.credstore.util.CsfUtil.checkPermission(CsfUtil.java:684)
at oracle.security.jps.internal.credstore.ssp.SspCredentialStore.getCredential(SspCredentialStore.java:562)
at oracle.bi.security.opss.CredentialReader.getPasswordCredential(CredentialReader.java:69)
at oracle.bi.security.opss.CredentialReader.getPasswordCredential(CredentialReader.java:57)
at oracle.bi.security.service.SystemUserValidator$ReadSystemUserCredentialsAction.run(SystemUserValidator.java:291)
at oracle.bi.security.service.SystemUserValidator$ReadSystemUserCredentialsAction.run(SystemUserValidator.java:278)
at oracle.bi.security.service.SystemUserValidator.readSystemUserCredential(SystemUserValidator.java:186)
at oracle.bi.security.service.SystemUserValidator.validateSystemUserCredentials(SystemUserValidator.java:146)
at oracle.bi.security.service.SystemUserValidator.access$000(SystemUserValidator.java:26)
at oracle.bi.security.service.SystemUserValidator$1.run(SystemUserValidator.java:107)
at oracle.bi.security.service.SystemUserValidator$1.run(SystemUserValidator.java:101)
at oracle.bi.security.service.SystemUserValidator.validate(SystemUserValidator.java:117)
at oracle.bi.security.service.SecurityServiceBean.initialise(SecurityServiceBean.java:89)
at oracle.bi.security.service.SecurityServiceBean.getAuthenticatedUserWithLanguageAndProperties(SecurityServiceBean.java:129)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

If you recive the above error, you don’t have permission to access to the analytics, permission saved  in Files called

system-jazn-data.xml

Located :-

 $DOMAIN_HOME/config/fmwconfig

Edit the files and add these lines :-

   

Or copy this file from another OBIEE Environment after backup the old one, and restart AdminServer and managed Server

Thank you
Osama Mustafa

[Security:090482]BAD_CERTIFICATE alert was received from Hostname

[Security:090482]BAD_CERTIFICATE alert was received from Hostname. Check the peer to determine why it rejected the certificate chain (trusted CA configuration, hostname verification). SSL debug tracing may be required to determine the exact reason the certificate was rejected.>
javax.net.ssl.SSLKeyException: [Security:090482]BAD_CERTIFICATE alert was received from Hostname. Check the peer to determine why it rejected the certificate chain (trusted CA configuration, hostname verification). SSL debug tracing may be required to determine the exact reason the certificate was rejected.
at com.certicom.tls.interfaceimpl.TLSConnectionImpl.fireException(Unknown Source)
at com.certicom.tls.interfaceimpl.TLSConnectionImpl.fireAlertReceived(Unknown Source)
at com.certicom.tls.record.alert.AlertHandler.handle(Unknown Source)
at com.certicom.tls.record.alert.AlertHandler.handleAlertMessages(Unknown Source)
at com.certicom.tls.record.MessageInterpreter.interpretContent(Unknown Source)
at com.certicom.tls.record.MessageInterpreter.decryptMessage(Unknown Source)
at com.certicom.tls.record.ReadHandler.processRecord(Unknown Source)
at com.certicom.tls.record.ReadHandler.readRecord(Unknown Source)
at com.certicom.tls.record.ReadHandler.readUntilHandshakeComplete(Unknown Source)
at com.certicom.tls.interfaceimpl.TLSConnectionImpl.completeHandshake(Unknown Source)
at com.certicom.tls.record.ReadHandler.read(Unknown Source)
at com.certicom.io.InputSSLIOStreamWrapper.read(Unknown Source)
at sun.nio.cs.StreamDecoder.readBytes(StreamDecoder.java:264)
at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:306)
at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:158)
at java.io.InputStreamReader.read(InputStreamReader.java:167)
at java.io.BufferedReader.fill(BufferedReader.java:136)
at java.io.BufferedReader.readLine(BufferedReader.java:299)
at java.io.BufferedReader.readLine(BufferedReader.java:362)
at weblogic.nodemanager.server.Handler.run(Handler.java:71)
at java.lang.Thread.run(Thread.java:662)

You need to recreate the certification again :-
Depend on your Operating system :-

$WL_HOME/server/bin/setWLSEnv.sh Or setWLSEnv.cmd

cd $WL_HOME/server/lib

 Copy DemoIdentity.jks to another directory as backup.

then inside the WLS_HOME/server/lib run:-

Generate the private key.

java utils.CertGen -keyfilepass DemoIdentityPassPhrase -certfile newcert -keyfile newkey 

Import the key generated

java utils.ImportPrivateKey -keystore DemoIdentity.jks -storepass DemoIdentityKeyStorePassPhrase -keyfile newkey.pem -keyfilepass DemoIdentityPassPhrase -certfile newcert.pem -alias demoidentity 

 Restart AdminConsole and Nodemanager and try to start managed server.

Thank you
Osama mustafa

Oracle Application Adapter installation.

Regarding to Oracle Documentation :-

The Application Adapter installer for 11g Release 1 (11.1.1.3.0) is applicable for the Oracle Service-Oriented Architecture (SOA) Suite and Oracle Service Bus (OSB). The Application Adapters that are installed can be used with Business Process Execution Language (BPEL), Mediator, Business Process Management (BPM), and OSB components. Using this installer, Application Adapters can be installed in a standalone SOA environment, standalone OSB environment, or mixed (SOA and OSB) environment.

You can check from here

The installation is not that hard , it’s all about configuration. i will post about later.

You Can Download it from here.

Operating system : Oracle Linux.

Installation Steps :-

As You see you should installed Oracle SOA Or Oracle OSB.
If you are using Oracle SOA the path will be like the below :-
\Oracle_SOA1\
For Oracle OSB :-
\Oracle_OSB1\
Be Notice this application installed in the following Path :-
\Oracle_SOA1\soa\thirdparty\ApplicationAdapters\
Thank you 
Osama mustafa

unrecognized class file version

This error appear on linux while trying to run iwae.sh ( Oracle Application adapter ).

Starting java

—————————————————————
Exception in thread “main” java.lang.ClassFormatError: com.ibi.bse.gui.BseFlashScreen (unrecognized class file version)
at java.lang.VMClassLoader.defineClass(libgcj.so.7rh)
at java.lang.ClassLoader.defineClass(libgcj.so.7rh)
at java.security.SecureClassLoader.defineClass(libgcj.so.7rh)
at java.net.URLClassLoader.findClass(libgcj.so.7rh)
at java.lang.ClassLoader.loadClass(libgcj.so.7rh)
at java.lang.ClassLoader.loadClass(libgcj.so.7rh)
at gnu.java.lang.MainThread.run(libgcj.so.7rh)

Solution :-

 export JAVACMD=/Oracle/Java/bin/java

And try again.

Thank you
Osama mustafa 

java.lang.ClassNotFoundException: oracle.dms.wls.DMSServletFilter

This Error Appeared while trying to start managed Server “edq_server1” , The starting results it’s completed with successfully status but some deployment end with Failed status , which mean edq_server will not work correctly, therefore i checked the logs which the below error :-

Caused By: java.lang.ClassNotFoundException: oracle.dms.wls.DMSServletFilter
        at weblogic.utils.classloaders.GenericClassLoader.findLocalClass(GenericClassLoader.java:297)
        at weblogic.utils.classloaders.GenericClassLoader.findClass(GenericClassLoader.java:270)
        at weblogic.utils.classloaders.ChangeAwareClassLoader.findClass(ChangeAwareClassLoader.java:64)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
        at weblogic.utils.classloaders.GenericClassLoader.loadClass(GenericClassLoader.java:179)
        at weblogic.utils.classloaders.ChangeAwareClassLoader.loadClass(ChangeAwareClassLoader.java:43)
        at weblogic.servlet.internal.WebComponentContributor.getNewInstance(WebComponentContributor.java:224)

To solve this error :-

cd /u01/app/oracle/product/fmw/wlserver_10.3/common/nodemanager
vi nodemanager.properties

And search for 

StartScriptEnabled=false

change it to

StartScriptEnabled=true

Restart Node manager and try again.
Thank you
Osama Mustafa